1

The Cast of Olympians and Titans

Now that you have everything you need, it’s time to open OmniGraffle. If you’d like, you can enter full screen mode by choosing View ▸ Enter Full Screen (Control-Command-F).

Start by creating a new document and then set up some basic document parameters as follows:

  1. Choose File ▸ Resource Browser (Shift-Command-N) to open the Resource Browser.

  2. In the left sidebar under Templates, choose Imperial Units, and then select the Auto-Resizing template. The reason why you want to use an Auto-Resizing template is to allow the canvas to automatically expand as you create the diagram.

    The Resource Browser
  3. Click New Document to create a new Untitled document in OmniGraffle.

    An OmniGraffle window with a blank canvas
  4. In the Canvas inspectors (Inspectors ▸ Canvas, or Command–4), do the following:

    • Open the Units inspector, and change the units of measurement from Inches to Pixels.
    • Open the Diagram Layout inspector and turn on Auto layout.
    The Diagram Layout pane

    The reason for turning on Auto layout right now is to permit the flow of objects when you start inputting names for the Gods, Titans, and such. If Auto layout wasn’t turned on, there would be no visible flow or hierarchy to the objects as they’re created, and it would be hard to tell what belonged where.

With the basic bits of your OmniGraffle document set up, go ahead and save the file. Choose File ▸ Save and choose a location on your Mac (or in an OmniPresence folder) where you store OmniGraffle files.

Use the Save sheet in OmniGraffle to choose a location to save your tutorial document

Congrats! You’ve made it past the first phase of the tutorial; you’ve learned something about:

  • The Resource Browser
  • Templates
  • How to use an Inspector
  • And a couple of super-handy keyboard shortcuts

Take the accomplishments as they come! There’s a lot more to learn.

Using the Outline Editor to Create the Greek Universe

When creating a diagram, whether it’s a flow chart for a process you’re trying to whittle down to be more efficient or a list of family members, the biggest part of that process is entering all of the information. Names, tasks, whatever they may be; it takes some effort. Fortunately, you can do this quickly using the Outline Editor in OmniGraffle.

The Outline Editor is located in the Contents section of the sidebar on the left side of OmniGraffle’s window. To use the Outline Editor, choose View ▸ Show Contents ▸ Outline Editor (Option-Command–3), or click the Outline Editor button in the Contents divider.

The sidebar, showing the Outline Editor being selected

Now all you need to do is figure out where to start. Fortunately for us, Hesiod’s Theogony gives us a clue:

“First Chaos came to be, but next… Earth… and dim Tartarus in the depth of the… Earth, and Eros…”

That gives us some of the basic framing of who the primordial Greek gods are. According to Hesiod, Chaos was a formless thing from which the universe was created. Others believe that Chaos had to come from somewhere—Chronos (Time) and Ananke (Inevitability) are the likely source—but we will leave those out of the picture.

Now all you need to do is start typing; click where it says Click to add a topic. After clicking Click to add a topic, you’ll notice that your first object (labeled Topic) appears on the canvas. And when you press Return, another object appears, and so forth.

Enter Chaos, press Return and then press Tab. Notice that OmniGraffle indents the next Topic and adds an open disclosure triangle (▾) to the left of Chaos:

Adding structure to your diagram with the Outline Editor

Underneath Chaos, enter the following, but don’t press Return after entering Eros:

  • Erebus (Darkness)
  • Nyx (Night)
  • Gaia (Earth)
  • Tartarus (the Underworld and, later, the prison for the Titans)
  • Eros (Love)

Tip
If you press Return after entering Eros, you’ll create an object that you won’t need right now. To stop that from happening, press Esc (short for Escape) instead of pressing Return. This ceases editing/entry mode.

However, if you pressed Return instead of Esc, you can press Command-Z (Undo) to remove the extra Topic object from the outline and canvas.

When you have finished, this is how the sidebar and part of the canvas should appear:

The Outline Editor and four named objects on the canvas

These six—Chaos, Erebus, Nyx, Gaia, Tartarus, and Eros—are known as the first of the primordial deities; they form the foundation of your work in this tutorial. It makes sense that everything starts with Chaos, since the cosmos started with a bang and from which everything in the known universe exists.

After what some might think is an already busy day (“Create darkness and night; check. Create Earth; check. Create the Underworld; check.”, and so on), Chaos decided to hang it up and let the primordial deities take it from there. So, let’s fill out the tree some more.

Into the Night—Adding Nyx’s Children, Grandchildren, and More

Start by clicking to the right of Nyx in the Outline Editor. As you’ll notice, the cursor appears wherever you clicked in the name. If you clicked to the right of Nyx, the cursor should appear at the end.

The cursor placed at the end of the word Nyx

Press Return and then press Tab. Pressing Return, as you know, creates a new object in the outline; however, pressing Tab indents that object to create a child object of Nyx.

Table 1 provides the list of names to enter underneath Nyx. In the first column, you will occasionally see one of the following:

  • [tab] — When you see this, press the Tab key prior to entering the name on that row. This indents the next entry, creating a child of the previous row.
  • [shift-tab] — When you see this, hold down the Shift key and then press the Tab key prior to entering the name on that row. This outdents the next entry, to take you up a level in the hierarchy.
  • [shift-tab][shift-tab] — When you see this, hold down the Shift key and then press the Tab key twice prior to entering the name on that row. This outdents the next entry, taking you two levels higher in the hierarchy.

There are two possible actions you’ll see the third column, End of Line Action:

  • [return] — This simply means that you need to press the Return key after entering the name.
  • [esc] — When you reach the end of the list, you will press the Esc (or Escape) key to accept the text you’ve just entered, but not create a new entry. If you were to press Return by mistake, you can press Command-Z to undo that action.

With those details clarified, perform the actions detailed in Table 1. Refer to the image in the fourth column of the table to compare how the names appear in the Outline Editor of your document. Don’t worry if you have made any mistakes; this is a learning process. The key here is to get comfortable with using the Outline Editor in OmniGraffle.

Note
If you’d like, you can watch the following video to see how OmniGraffle builds the structure of the diagram as you enter the names in Table 1.

Table 1: Names to enter under Nyx
Indent/ Outdent Name to Enter End of Line Action
Nyx [return]
[tab] Aether [return]
[tab] Aergia [return]
[shift-tab] Hemera [return]
[tab] Thalassa [return]
[tab] Telchines [return]
Halia [return]
[shift-tab]
[shift-tab]
Moros [return]
Apate [return]
Dolos [return]
Nemesis [return]
The Hesperides [return]
[tab] Aigle [return]
Erytheia [return]
Hesperethusa [return]
[shift-tab] The Moirai (The Keres) [return]
[tab] Clotho [return]
Lachesis [return]
Atropos [return]
[shift-tab] Oizys [return]
Momus [return]
Hypnos [return]
[tab] The Oneiroi [return]
[tab] Morpheus [return]
Phobetor [return]
Phantasos [return]
[shift-tab]
[shift-tab]
Thanatos [return]
Philotes [return]
Geras [return]
Eris [return]
[tab] Dysnomia [return]
Atë [return]
Lethe [return]
Limos [return]
Algos [return]
Hysminai [return]
Makhai [return]
Phonoi [return]
Androktasiai [return]
Amphilogiai [return]
Horkos [return]
[shift-tab] Charon [esc]

After you have finished entering the names listed in Table 1, this is how the list should appear in the Outline Editor:

This is how the Contents sidebar should look after you have entered all of the names in this table

Tip
As you may have noticed, one of Eris’ children is named Atë. If you are wondering how to create the ë character, press Option-u on the keyboard (this creates the double-dots ¨ to go over the next character you type), and then press e.

After entering all of those names, this is how your Outline Editor and the objects on your canvas should appear:

The Outline Editor shows the list of names, while the objects appear in a hierarchical diagram on the canvas

Without going into too much detail about who all of those gods and goddesses are, Erebus and Nyx are Darkness and Night, respectively, so you can assume their offspring mainly consist of “things that go bump in the night.” It’s also worth noting that only Aether (Light) and Hemera (Day) are considered direct descendents of Erebus and Nyx; Nyx alone bore the remainder of her children (there’s a lot of that—parthenogenesis—throughout Greek mythology).

Note
It’s also worth noting that the only thing that Zeus was really afraid of was Nyx. One could deduce that Zeus had a nightlight and a favorite wubby to protect him from the night.

Gaia: Mother to Many (and Our Home)

After Chaos ventured off and created darkness, light, day, and night, Gaia got to work on her own little side project—adding a few things to the Earth. Gaia created Uranus (the heavens and sky), the Ourea (hills of the land), and Pontus (the sea). And, once Gaia had her “heaven” on earth (Uranus), the two of them got together and created the twelve Titans.

So, let’s add them to the family. In the Outline Editor, click the disclosure triangle (▸) to the left of Nyx to hide her lineage, and then locate and click to the right of Gaia. Press Return and then press Tab to indent the next entry underneath Gaia. As with Table 1, use the list in Table 2 and enter the names in the Outline Editor.

Note
If you’d like, you can watch the following video to see how OmniGraffle builds the structure of the diagram as you enter the names in Table 2.

Table 2: Names to enter under Gaia
Indent/ Outdent Name to Enter End of Line Action
Gaia [return]
[tab] Uranus [return]
[tab] The Titans [return]
[tab] Oceanus [return]
Tethys [return]
Coeus [return]
Phoebe [return]
Hyperion [return]
Theia [return]
Cronus [return]
Rhea [return]
Themis [return]
Mnemosyne [return]
Iapetus [return]
Crius [return]
[shift-tab]
[shift-tab]
Cyclopes [return]
[tab] Brontes [return]
Steropes [return]
Arges [return]
[shift-tab] The Hecatonchires [return]
[tab] Cottus [return]
Briareos [return]
Gyges [return]
[shift-tab] The Ourea [return]
[tab] Aitna [return]
Athos [return]
Helikon [return]
Kithairon [return]
Nysos [return]
Olympus 1 [return]
Olympus 2 [return]
Oreios [return]
Parnes [return]
Tmolus [return]
[shift-tab] Pontus [esc]

After you have finished entering the names listed in Table 2, this is how the list should appear in the Outline Editor:

This is how the Contents sidebar should look after you have entered all of the names in this table

And, since Pontus was the primordial god of the sea, he, with Gaia, decided there needed to be a few more sea gods. As with Tables 1 and 2, use the list in Table 3 and enter the names in the Outline Editor.

Note
If you’d like, you can watch the following video to see how OmniGraffle builds the structure of the diagram as you enter the names in Table 3.

Table 3: Names to enter under Pontus
Indent/ Outdent Name to Enter End of Line Action
Pontus [return]
[tab] Nereus [return]
Thaumus [return]
Phorcys [return]
Ceto [return]
Eurybia [esc]

After you have finished entering the names listed in Table 3, this is how the list should appear in the Outline Editor:

This is how the Contents sidebar should look after you have entered all of the names in this table

If you zoom way, way out on the Canvas, this is how the entire diagram appears at this point:

The diagram, when zoomed out, looks way too small for recognition

As you can see, the diagram is getting pretty jam-packed, and we’ve barely scratched the surface with just over 85 objects in the outline. You’ve also seen how, um, “prolific” some of the gods and goddesses have been (and we haven’t even gotten to Zeus yet!).

Before moving on, go ahead and save your work (if you haven’t already done so), and then close the file.

Warning
If you are reading this tutorial on an iOS device—either in iBooks, another EPUB reader—please take the time to switch to your Mac before downloading the OmniOutliner file mentioned in the next section.

While downloading the OmniOutliner file on your iOS device won’t cause an irreversible singularity, you do, however, need this file on your Mac so you can press forward with this tutorial.

Importing an Outline from OmniOutliner

This concludes the first part of the tutorial, in which you learned how to use the Outline Editor for creating a diagram of structured objects. To prepare for Part 2, we created a separate OmniOutliner file which you can download from our website and open in OmniGraffle. This file, GreekMythology.oo3, contains 220 names (compared to the 86 you’ve just entered) and eight levels of hierarchy.

Note
Before you get upset and wonder why we had you go through this entire exercise, all of that was necessary. Using the Outline Editor helps you get acquainted with one tiny feature that can save you a ton of time when you’re trying to get started on a project.

Later, you’ll see how to use the Outline Editor along with the Selection Matrix (the button to the right in the Contents section of the sidebar).

You don’t need OmniOutliner to work with the file you just downloaded. Instead, you can use OmniGraffle to open (or import) the OmniOutliner file, as follows:

  1. In OmniGraffle, choose File ▸ Open (Command-O), and then select the OmniOutliner file you downloaded (chances are, it downloaded to your Mac’s Downloads folder).
  2. After selecting the OmniOutliner file, click Open; this opens the Import Outline window.
  3. Click the popup menu at the top of the window and choose Automatic Layout ▸ Hierarchical.
    The Import Outline dialog widnow

    The Import Outline window presents you with a preview of what the diagram will look like, and you will also see options adjust the Style Fields and Outline Columns, but you can ignore those.

    The diagram preview
  4. Click OK to import the contents of the OmniOutliner file as a hierarchical diagram.

That’s it; pretty simple. Your final step is to save this file, so choose File ▸ Save (Command-S), and save the OmniGraffle file to a location where you normally save OmniGraffle files on your Mac’s hard drive. If you don’t already have such a place reserved, you could choose the Documents folder, and then create a New Folder (Shift-Command-N) and name that something along the lines of OmniGraffle Tutorial.

Now you are ready to proceed to Part 2 of the tutorial.

Note
Part 2, Styling and Laying Out the Objects, is the longest part of the tutorial. Now might be a good time to take a short break. Get some air, go for a run or a ride, snuggle with your cat, and prep your favorite beverage before you continue.

If it’s getting late wherever you are, you may also find it helpful to step away from the tutorial and come back to it in the morning. Not that we don’t think you’re capable of pulling an all-nighter like in grad school, but, well, we care about you. We want you to absorb all of this stuff, and you can’t be an absorbant sponge if you’re feeling woozy and your brain is mush.