Support

“Incompatible Plug-ins Disabled” error after updating Apple Mail

Update for macOS High Sierra users: it is no longer be necessary to install Clip-o-Tron in order to clip emails to OmniFocus. Learn more here.

After dismissing this error, High Sierra users should be able to continue clipping to OmniFocus without further reinstallation. This article is no longer applicable to High Sierra users, but may still be useful for those looking to resolve this error on earlier versions of Mac OS X.

Sometimes updates to Mail disable the Clip-o-Tron clipping plug-in OmniFocus uses, even if there isn’t a compatibility issue. If you’ve run an OS X software update that includes a new version of Apple Mail, you’ll likely get an “Incompatible Plug-ins Disabled” error message afterward that mentions that “Mail has disabled the following plug-ins: OmniMailMessageServiceEnabler”.

Incompatible Plug-ins Disabled

The good news is that even though the message suggests that our plug-in needs to be updated, it’s already compatible - all that’s required is to reinstall it! To fix this issue, quit Mail, then OmniFocus 2 users on macOS Sierra and earlier should open the OmniFocus Clip-o-Tron application to install the latest update of that plugin. Follow the instructions on this page to download and install the standalone Clip-o-Tron 3001 installer. We might recommend leaving the OmniFocus Clip-o-Tron in your Applications folder, so that you can quickly locate the installer whenever a Mail update disables our plug-in in the future.

If you’re using OmniFocus 1, open the Clippings tab of OmniFocus > Preferences. Click the button at the bottom of the window to install the v1 Clip-o-Tron 3000, reopen OmniFocus and Mail, and you should be back in business.

Last Modified: Oct 2, 2017

Can we help?

support@omnigroup.com
+1 206-523-4152 or 800-315-OMNI

Was this article helpful?

Still need help?

support@omnigroup.com
+1 206-523-4152 or 800-315-OMNI