Support Produced by OmniGraffle 7.5 test 2017-09-15 03:22:04 +0000 phone/email/twitter Layer 1 +1 206-523-4152 or 800-315-OMNI

Omni apps on macOS 10.15 Catalina

With the release of macOS 10.15 Catalina, we’ve been working on compatibility updates for our currently-shipping apps. Please contact our Support team if you encounter a problem not listed below while running a currently-shipping app on macOS Catalina.

OmniFocus for Mac

  • OmniFocus 3.4.2 has no known issues on macOS Catalina.

OmniGraffle for Mac

  • When first launched on macOS Catalina, OmniGraffle 7.11.3 and earlier will request permission to present notifications. Choosing “Don’t Allow” will not cause any problems, and a future update will stop the request from appearing at all.
  • Template documents (.gtemplate files) do not generate QuickLook previews on macOS Catalina.

OmniOutliner for Mac

  • When first launched on macOS Catalina, OmniOutliner 5.4.2 and earlier will request permission to present notifications. Choosing “Don’t Allow” will not cause any problems, and a future update will stop the request from appearing at all.
  • OmniOutliner 5.4.2 will crash when attempting to customize the toolbar.

OmniPlan for Mac

  • OmniPlan 3.13.1 for Mac is available and includes macOS Catalina compatibility fixes.
  • When first launched on macOS Catalina, OmniPlan 3.13 and earlier will request permission to present notifications. Choosing “Don’t Allow” will not cause any problems. (This prompt no longer appears at all in OmniPlan 3.13.1.)
  • A system change in macOS Catalina can cause versions of OmniPlan prior to OmniPlan 3.13.1 to write corrupted change logs. Files corrupted while running previous versions of OmniPlan on macOS Catalina can be successfully opened by OmniPlan 3.13.1 and newer.

OmniGraphSketcher

  • OmniGraphSketcher will not launch or run on Catalina. We cannot offer support for the open source release, GraphSketcher, but it is compatible with Catalina.

OmniDazzle, OmniDictionary

  • Catalina does not support these apps. They will not launch or run. If you intend to continue using them, you should remain on Mojave or earlier.

Previous Versions

While we have not extensively tested older versions of Omni apps on macOS Catalina, we are not aware of any major compatibility issues that did not already exist in previous versions of macOS. If you’re updating to Catalina from Mojave or earlier, please review the articles below before updating your Mac:

Last Modified: Dec 10, 2019

Can we help?

support@omnigroup.com
+1 206-523-4152 or 800-315-OMNI

Was this article helpful?

Still need help?

support@omnigroup.com
+1 206-523-4152 or 800-315-OMNI