The Outline
The Outline is the center of everything you do in OmniOutliner. It allows you to create and organize your content, offers a hierarchy of rows to create the structure you seek, and can be easily updated with styles you choose.
An OmniOutliner Pro outline is composed of one or more Rows and one or more Columns, with editable cells available at each intersection of row and column. Rows are displayed in a Hierarchy, allowing you to create simple lists, complicated outline structures, or something right in the middle.
Rows
When working in the Outline,
Rows
are the building blocks of your content.
Rows may be as simple as a line of text;
or they may include
Row Handles
for moving, collapsing, or expanding sections;
Status Checkboxes
for managing lists and tasks;
or
Notes
for adding anything relevant to your work.
Rows can even span multiple columns.
You can hide or show any attributes of a row,
other than the text of the row itself.
Text can also be collapsed into a single line on Mac,
by setting
Show Full Row Text
to When Editing.
Editing Rows
Tap or click a row cell to begin editing. A cursor will appear in the cell, and you can add text or other data, depending on the column type.
To learn more about available column types, see Column Types in the Inspectors chapter.
Row Handles
Row Handles can be used to move rows, along with any indented (child) rows, or can be used to hide or show indented rows. The style of the row handle indicates whether there are any indented rows.
Row Handles will display as:
Bullet —
Does not contain any indented rows.
Collapsed Disclosure Arrow —
An arrow pointing to the row indicates that the row
contains indented rows,
which are currently hidden.
Click or tap this handle to show the next level of indented rows.
On Mac,
Option + click to expand all indented rows.
Expanded Disclosure Arrow —
An arrow pointing down indicates that the row
contains indented rows,
which are currently displayed.
Click or tap this handle to collapse indented rows.
On Mac,
Option + click to collapse all indented rows.
In addition to clicking or tapping the arrows, you can use keyboard shortcut keys for the Expand and Collapse–related commands.
On Mac,
you can hide handles,
or set them to show only when hovering a cursor over the handle.
The setting can apply to specific rows or the entire document,
by using the
Row Inspector.
Even with handles hidden,
the
Expand
or
Collapse
commands continue to work.
Status Checkboxes
If you would like to track the status for items in your outline, you can display a Status Checkbox next to each row.
Turn the display of Status Checkboxes on or off for your document using the Show Status Checkboxes menu command on Mac, the Show Row Status toggle in the Document Inspector on Mac, or the Row Status toggle in the Document Inspector on iPad, iPhone, Apple Vision Pro.
The state of each checkbox is saved, even when they are hidden, allowing you to quickly update the appearance without losing information.
On Mac, there are additional options for setting status on a given row. Read about the Set Status submenu to learn more.
Notes
OmniOutliner supports adding notes to individual rows.
On the leading edge of the Outline is a narrow Note column.
This column may appear empty,
but hovering the cursor over it will reveal a
icon next to the row.
- Click or tap this icon to add note text to the row,
or drag in attachments.
Once text or attachments have been added to a note,
the
icon will display all the time,
instead of only when hovering a cursor. - Selecting the
Note icon will expand or collapse the note for that row. - To hide the Notes column, choose Note from the Columns submenu of the View Menu on Mac, or toggle Notes in the Columns Inspector on iPad, iPhone, and Apple Vision Pro.
Notes are displayed in the
Topic Column by default,
but you can choose to display notes across all columns.
To change between single column or spanning columns,
update the
Notes Span Columns
setting on iPad, iPhone, or Apple Vision Pro,
or the
Inline Notes
setting on Mac.

Notes are displayed immediately below the related row.
On Mac,
you can choose to show them in a pane at the bottom of your Outline,
by selecting Display in Pane from the
Notes
submenu of the
View Menu.

Columns
While rows allow you to organize and group your information, columns allow you to expand the information for each row, while still respecting the hierarchy defined by your rows.
Continue reading to learn more about columns:
Topic Column
Every document contains a Topic Column, with a narrow Notes indicator on the leading edge.
The Topic column has unique properties:
- It can be organized into a hierarchy; when the organization of the Topic column changes, other columns rearrange as well.
- It can have a fixed width, or be set to automatically adjust to fit the width of the window or other columns.
If you would like your document to use only a single column, whether for streamlining or simplicity, you may want to consider OmniOutliner Essentials. With a license for OmniOutliner Pro, you can turn off Pro features in the License panel, which provides an easy way to create Essentials-compatible documents for sharing.
Adding a Column
To add a column on Mac:
- Select the Add Column button in the Toolbar
- Use the Add Column menu command
To add a column on iPad, iPhone, or Apple Vision Pro:
- Select the Add Column button in the Toolbar
- Select Add Column in the Columns Inspector
Removing a Column
To remove a column on Mac:
- Select the column by clicking the column header, and press the Delete key
- Select Remove Column from the Organize Menu
- Select Remove Column from the Column Header Menu
To remove a column on iPad, iPhone, or Apple Vision Pro:
- Select Delete from the Column Header Menu
- Select Remove Column in the Columns Inspector for a specific column
Editing a Column
Most column editing features are available cross-platform, using the Column Type Inspector on Mac, or Columns Inspector on iPad, iPhone, Apple Vision Pro.
On Mac, you can quickly edit the title of a column by double-clicking the column header, adjust the width of any column by dragging the column borders, and access additional options in the Column Header Menu.
On iPad, iPhone, and Apple Vision Pro, you can adjust the width of any column by dragging the column handle, and access additional options in the Column Header Menu, including quick access to the Columns Inspector by selecting Edit.
Column Headers
Outlines with a single column do not display the column header, as there’s no need to distinguish between multiple columns. Once a second column is added, the headers are shown above each column.
This is the Automatic column header behavior, which can be changed by choosing another option from the Column Headers submenu on Mac, or the Column Headers section of the Document Inspector on iPad, iPhone, or Apple Vision Pro.
Autosizing
Autosizing allows the Topic Column to take as much space a possible, given the size of the containing window, and the width of other columns. It is only available for documents with more than one column.
To switch between width modes on Mac:
- Select Auto in the Column Type Inspector
- Select Autosize from the Topic Column Header Menu
- Select Autosize Topic from the Columns submenu of the View Menu
To switch between width modes on iPad, iPhone, or Apple Vision Pro:
- Select Autosize in the Column Type Inspector for the Topic column
- Select Autosize from the Topic Column Header Menu
Hierarchy
Every document has a structure to it, derived from the placement of rows: above or below, indented or outdented, individual or grouped.
We refer to this structure as the hierarchy of your document; keep reading to learn more about:
Levels and Sections
The first row you add to your document lives at the top level, and creates the first section of your outline; we refer to this row as a Level 1 row. Creating another row at the same level will result in your document having two Level 1 rows, and therefore two sections; we refer to these rows (and sections) as peers (or siblings).
Indenting a row makes it a Level 2 row, and creates a subsection; indenting the row below makes it a Level 3 row, and creates a subsubsection; and so forth.
Specific levels can have consistent, document-wide styling applied, using Structural Styles.
Selecting Rows
To select a single row,
click or tap the
Gutter,
the space between the
Row Handle
and
Note
icon.
To select multiple rows using a hardware keyboard:
- Shift + click to select a range of rows
- Command + click to select individual rows
- Shift+Up arrow or Shift+Down arrow to change your selected range
To select multiple rows on iPad, iPhone, or Apple Vision Pro, use Select Mode.
Organizing Rows
OmniOutliner 6 has several options for organizing rows:
Sorting Rows
The fastest way to organize your rows is using the Sort Outline/Sort Selected Rows command:
- Sort Outline — With no rows selected, this command changes the order of all rows in your document.
- Sort Selected Rows — With two or more rows selected, this command changes the order of only the selected rows.
Indenting and Outdenting Rows
You can organize rows by indenting selected rows under another row in order to create a Group.
Depending on the platform, you can indent by selecting one or more rows, and:
- Pressing Tab
- Pressing Command+]
- Using the Indent command (Mac, iPad)
- Tapping the
Indent
button (iPad, iPhone, Apple Vision Pro)
The Row Handle updates to a Disclosure Arrow to indicate that the new group contains rows. Tap the disclosure arrow to collapse and expand the group. When expanded, a vertical line descending from the disclosure arrow shows which rows are part of the group.
You can also outdent selected rows from a group, restoring their positions as peers of the enclosing row.
Depending on the platform, you can outdent by selecting one or more rows, and:
- Pressing Shift+Tab
- Pressing Command+[
- Using the Outdent command (Mac, iPad)
- Tapping the
Outdent
button (iPad, iPhone, Apple Vision Pro)
Copying and Pasting Rows
Copying and pasting is another way of organizing rows, and can be handy when your original rows are in different parts of your document.
On Mac or iPad:
- Select one or more rows to copy.
- Use the Copy command or shortcut.
- Select your destination row.
- Use the Paste command or shortcut.
On iPad, iPhone, or Apple Vision Pro:
- Touch and hold a row until the shortcut menu appears.
- Select the
Copy
command. - Touch and hold your destination row.
- Select the
Paste
command. - Choose to paste Above, Below, or Inside the destination row.
- If you want to copy multiple rows, use Select Mode before copying.
Copying and pasting a Group will include all contained rows.
Dragging and Dropping Rows
You can also drag rows to organize them.
On Mac:
- Select one or more rows you would like to move.
- Drag one of the Row Handles to move your selected rows, and drop them in the new location.
On iPad, iPhone, or Apple Vision Pro:
- Touch and hold on a row to pick it up.
- Drag it to the new location, and remove your finger to drop them.
- If you want to move multiple rows, use Select Mode before dragging.
As you drag rows over other rows, they will either highlight (on Mac) or move out of the way (on iPad, iPhone, Apple Vision Pro) to indicate where the dropped rows will land.
Dragging and dropping a Group will include all contained rows.
Filtering the Outline
If you have a long document, filtering your outline can quickly surface what you’re looking for, no matter where it is located in your document.
Use the
Filter/Go to Filter Field
command
or select the
Filter
button to
show the Filter bar at the top of your document.
Once the Filter bar displays, you can:
- Enter search terms to filter the outline, so that only rows and notes containing those terms display.
- Select the
Filter button to
change the scope of the filter from the default Entire Document
to a specific column, or the Notes field. - Select Save (as) Filter, if you would like to use this filter in the future.
- Select the
button to clear the field,
and close the Filter bar.
To create more complex filters, or use filters that you have saved, read about the Filters Tab.
Styles
Styling in OmniOutliner Pro can be quite sophisticated, and can affect the whole document, certain types of content (such as columns, rows, or even specific levels of rows), or individually selected rows or blocks of text.
Styles are automatically or manually applied, depending on whether they are:
- Structural Styles — automatically applied to classes of objects
- Named Styles — manually applied on top of structural styles
Structural Styles
Structural Styles are sets of style attributes that apply to elements of the document, based on the structure of the document.
Structural Styles always include:
- Whole Document — Properties that apply to all rows in the document.
- Level 1 Rows — Properties that apply only to top-level rows.
- Column Titles — Properties that apply to all column titles.
- Notes — Properties that apply to all notes.
- Topic — Properties that apply only to the Topic Column.
Structural Styles may include:
- Level 2 Rows — Properties that apply only to second-level rows.
- Level 3 Rows — Properties that apply only to third-level rows.
- Level n Rows — Properties that apply only to n-level rows.
- Columns — Properties that apply only to specific columns, much like the Topic style above; each column is listed by Column Name.
Since Structural Styles are applied based on how you structure your outline, the style for a row may change as you reorganize your document.
It is possible for multiple Structural Styles to apply to a given element of your document; see Layering Styles to learn more.
Configuring Styles on Mac:
- Select the style in the Styles Tab
- Use the Selection Style Group Inspectors
Configuring Styles on iPad, iPhone, or Apple Vision Pro:
- Use the Edit Styles sub-inspector
- Tap on the Style you would like to edit
Named Styles
Named Styles are sets of style attributes that can be applied to to anything that supports style attributes, such as rows, columns, blocks of text, or even other styles.
Named Styles adjust any Structural Styles which already apply to an object. For example, you could apply a Heading style on top of a Level 1 Row style, in order to make the text bigger or change the font.
Using Named Styles on Mac:
- Named Styles are in the Styles Tab.
- Select one or more objects in the Outline, then click the checkbox next to a Named Style to apply it to your selection.
Using Named Styles on iPad, iPhone, or Apple Vision Pro:
- Named Styles are in the Apply Styles Inspector.
- Select one or more objects in the Outline, then tap the Named Style row to apply it to your selection.
Configuring Styles on Mac:
- Select the style in the Styles Tab
- Use the Selection Style Group Inspectors
Configuring Styles on iPad, iPhone, or Apple Vision Pro:
- Use the Edit Styles sub-inspector
- Tap on the Style you would like to edit
As with Structural Styles, editing a Named Style automatically updates the style of any objects to which it has been applied.
Layering Styles
Styles are applied in the following order, from most general to most specific, with specific items taking precedence over general items:
- Structural Style for Whole Document
- Alternate Row Color; see Alternate Rows
- Structural Style for Column Styles; see Column Style
- Structural Style for Level Styles
- Structural Style for Notes
- Named Styles, from uppermost to bottommost
- Styles applied directly to a selected row
- Styles applied directly to selected text
Looking at the same list in a slightly different way, styles are prioritized in the following order, with higher priority styles taking precedence over lower priority styles:
- Styles applied directly to selected text
- Styles applied directly to a selected row
- Named Styles, from bottommost to uppermost
- Structural Style for Notes
- Structural Style for Level Styles
- Structural Style for Column Styles; see Column Style
- Alternate Row Color; see Alternate Rows
- Structural Style for Whole Document
Linking and Copying Styles
There are two features that make it even easier to build out styles in OmniOutliner:
Linking Styles
Linking styles allows a secondary style to inherit traits from a primary style. As an example: you could configure Style A with a robust set of appearance changes, then link Style B to it with only a single font change. Any subsequent changes to Style A will also update Style B, while leaving untouched the font change in Style B, as inherited attributes are overridden by local attributes.
- Structural Styles can inherit traits from Named Styles
- Named Styles can inherit traits from Named Styles
- Named Styles can not inherit traits from Structural Styles
To link styles on Mac using Drag and Drop:
- Open the Styles Tab in The Sidebar
- Drag the Named Style that will be your source (Style A) for style attributes, and drop it on the Named or Structural Style that will inherit style attributes (Style B).
- Verify that the Styles are linked by selecting Style B, then viewing the Preview Inspector; you should see one or more attribute rows that begin with “inherited:”
To link styles on iPad, iPhone, or Apple Vision Pro:
- Open Edit Styles in the Document Inspector
- Tap on the Named or Structural Style that will inherit style attributes (Style B).
- Scroll to the Apply Styles section.
- Tap on the Named Style that will be your source (Style A) for style attributes.
See Copying and Pasting Styles for another approach.
Copying and Pasting Styles
On Mac, you can copy style attributes from one style to another:
- Open the Styles Tab in The Sidebar
- Select the Named or Structural Style with style attributes you would like to copy.
- Use
Copy Style (in the Format Menu or
More menu in the bottom of the Styles tab) - Select the Named or Structural Style to which you would like to apply the copied style attributes (Style B).
- Use
Paste Style (in the Format Menu or
More menu in the bottom of the Styles tab) - Verify that the style attributes have been successfully copied and pasted by selecting Style B, then viewing the Preview Inspector; you should see the pasted attributes.
- If your source Style was a Named Style, you will also likely see or more attribute rows that begin with “inherited:”; these will update as the linked Style is updated.
Style Swatches
In the Styles Tab and Preview Inspector on Mac, and in the Style Attributes Preview on iPad, iPhone, and Apple Vision Pro, Style Swatches provide a quick visual reference of Style attributes.
Possible swatch options include:
Empty —
No styles have been applied to the selection,
so only the Whole Document style applies.
Letter A —
Text-specific styles have been applied,
such as selecting a specific font.
Letter A with Color —
Text-specific styles have been applied,
including a color change,
such as selecting a specific font and updating the color.
Solid Color —
The style applies a background color to the selection.
Diagonal Color —
The style applies a transparent background color to the selection.
Split Color —
The style applies a background color to the selection,
and
Allow Customization of Alternate Dynamic Colors
is turned on for the
Dynamic Theme.
Split Partially Diagonal Color —
The style applies a transparent background color to the selection in one
of the
Dynamic Theme
colors.
Split Fully Diagonal Color —
The style applies a transparent background color to the selection in both
of the
Dynamic Theme
colors.
Checkerboard —
The style applies many different attributes.
Collapsed Disclosure Arrow —
An arrow pointing to the row indicates that the row
contains indented rows,
which are currently hidden.
Click or tap this handle to show the next level of indented rows.
On Mac,
Option + click to expand all indented rows.
Expanded Disclosure Arrow —
An arrow pointing down indicates that the row
contains indented rows,
which are currently displayed.
Click or tap this handle to collapse indented rows.
On Mac,
Option + click to collapse all indented rows.
button to clear the field,
and close the Filter bar.
More menu in the bottom of the Styles tab)
Empty —
No styles have been applied to the selection,
so only the Whole Document style applies.
Letter A —
Text-specific styles have been applied,
such as selecting a specific font.
Letter A with Color —
Text-specific styles have been applied,
including a color change,
such as selecting a specific font and updating the color.
Solid Color —
The style applies a background color to the selection.
Diagonal Color —
The style applies a transparent background color to the selection.
Split Color —
The style applies a background color to the selection,
and
Allow Customization of Alternate Dynamic Colors
is turned on for the
Split Partially Diagonal Color —
The style applies a transparent background color to the selection in one
of the
Split Fully Diagonal Color —
The style applies a transparent background color to the selection in both
of the
Checkerboard —
The style applies many different attributes.